Astinet merupakan produk dari Telkom selain Indihome.
Astinet ini diperuntukan untuk kalangan corporate tapi tidak menutup kemungkinan digunakan untuk perumahan atau perorangan kelebihan astinet adalah
layanan pure dedicated dan benar benar CIR 1:1 menjamin koneksi SLA 99% uptime.

Tentunya karena layanan ini bersifat profesional maka untuk harganya pun dipatok sangat tinggi yang tentu saja tidak akan terjangkau untuk user warnet, RT/RW net, maupun UKM.
Saat ini kantor saya membutuhkan koneksi yang dedicated dan stabil untuk dilewatkan jalur vpn IPsec ke luar negeri, walaupun sekarang sudah ada koneksi wireless 20 Mbps tapi sepertinya untuk koneksi internasional dirasakan kurang stabil.
Harapan satu-satu nya adalah menggunakan jaringan FO menggunakan produk telkom astinet,mungkin pembaca bertanya-tanya kenapa harus astinet?? jawabannya karena area kantor saya hanya ada jaringan FO telkom 🙂 .
Berdasarkan kebutuhan tersebut maka disepakati mengunakan paket astinet dengan ketentuan 5 Mbps Internasional dan 1 Mbps Lokal dengan konfigurasi routing BGP (https://agusprasetia.com/pengenalan-bgp-border-gateway-protocol/}.
Dari pihak telkom mereka memberikan konfigurasi sebagai berikut:

IP WAN (Global)
IP PE (Telkom) = 172.16.253.1/30
IP CE (Client) = 172.16.253.2/30
Vlan = 3770
Alokasi Port = 1
Bandwidth = 5 Mbps

IP WAN (Domestik)
IP PE (Telkom) = 172.16.253.5/30
IP CE (Client) = 172.16.253.6/30
Vlan = 3771
Alokasi Port = 2
Bandwidth = 1 Mbps
IP Public = 36.66.43.144/29
Routing = BGP
ASNumber Telkom = 64646

Dan ternyata dari pihak telkom tidak meberikan ASNumber untuk Peers nya walaupun sudah saya tanyakan jawabannya dari sisi telkom hanya memberikan 1 ASNumber.
Well its okay kita cari sendiri saja berapa ASNumber untuk IP publik yang diberikan pihak telkom.
Cara nya dengan buka terminal di Linux lalu ketikan perintah

$ whois -h whois.radb.net 36.66.43.144/29

atau bisa juga

$ whois -h whois.cymru.com 36.66.43.144/29

Hasilnya sesuai gambar dibawah ini

asnumber

Terlihat bahwa ASNumber yang bisa dipakai adalah 17974

Sekarang saat nya mengkonfigurasikan Mikrotik berdasarkan data yang kita miliki:

Masuk ke terminal Mikrotik kemudian pastekan script seperti dibawah ini

# Assign ip address di interface yang akan di gunakan
/ip address add address=172.16.253.2/30 interface="ether1" disabled=no #interface ke modem telkom port 1 GLOBAL
/ip address add address=172.16.253.6/30 interface="ether2" disabled=no #interface ke modem telkom port 2 DOMESTIK
/ip address add address=36.66.43.150/29 interface="ether3" disabled=no #interface ke server dengan ip publik
/ip address add address=192.168.66.254/24 interface="ether4" disabled=no #interface ke LAN

# Buat Routing BGP
/routing bgp instance set default as=64646
/routing bgp network add network=36.66.43.144/29
/routing bgp peer add name=”INTERNASIONAL” remote-address=172.16.253.1 remote-as=17974
/routing bgp peer add name=”LOKAL” remote-address=172.16.253.5 remote-as=17974

Jika koneksi sudah Established maka ketika kita jalankan perintah

/routing bgp peer print

akan muncul label “E” yang artinya BGP sudah UP.

bgp_established

Sampai disini BGP routing sudah bisa digunakan hanya diperlukan perintah src-nat supaya semua koneksi ke internet diarahkan ke ip publik.
Berikan perintah seperti ini:

/ip firewall nat add action=src-nat chain=srcnat to-addresses=36.66.43.144/29

Dan untuk koneksi dari lokal LAN ip 192.168.66.xxx jalankan perintah:

/ip firewall nat add action=src-nat chain=srcnat src-address=192.168.66.0/24 to-addresses=36.66.43.150

Silahkan di coba browsing melalui LAN dan cek ping dari server yang pakai ip publik 36.66.43.145 s/d 36.66.43.149.

4 thoughts on “ASTINET IX and IIX with BGP Routing”
  1. # Buat Routing BGP
    /routing bgp instance set default as=64646
    /routing bgp network add network=36.66.43.144/29
    /routing bgp peer add name=”INTERNASIONAL” remote-address=172.16.253.1 remote-as=17974
    /routing bgp peer add name=”LOKAL” remote-address=172.16.253.5 remote-as=17974

    Ini jenis routing eBGP
    Sebelumnya, aku mengira kita peering ke pihak Telkom menggunakan iBGP saja,
    nanti pihak telkom yang melakukan peering ke Luar “AS” menggunakan eBGP.

    Berarti as=64646 ini dikenal sebagai AS perusahannnya mas yh bukan milik Telkom lagi jika dilihat secara teknis.

Leave a Reply

Your email address will not be published. Required fields are marked *